Select objects through transparency

In v8i I'm able to select these objects or snap to points along the yellow line THROUGH the glass box.

In CE it seems I'm not able to do so. What am I doing wrong?

PS. I have Disable Drag Operations checked in both v8i and CE, but I don't think this is related to the problem.





Parents Reply
  • Thanks - I've now tried all options; Never/ Visible/ Always.

    Never; will not select anything inside the glass box (no matter how far in I zoom)

    Visible; First attempt at a tentative snap always shoots to a keypoint on the edge of the glass box, second attempt will select the object I want.

    Always; same as Visible.

    v8i quickly and accurately selects the geometry I want - something must be wrong with my CE settings, or is this standard behavior in CE. I really hope not.

    By the way - it something wrong with the Communities site? Posts take several minutes to load.

  • Related to this - in v8i I can snap to the point where I know there is a vertex in the geometry (even though it is obscured).

    In CONNECT, I'm not able to do this - have to rotate the object and snap on that vertex only when visible.

  • in v8i was INPUT options

    Locate Interiors: Never / Rendered or Filled / Rendered / Filled / Always.

    As far as I remember in CE the settings are the same.

    Mstn behave that is you have visible filled surface it will treat it as non transparent, and to get behind that surface you MUST be behind that surface.

    Another words: a) try to use Wireframe style to get to the points / edges

    b) try to use camera focus distance stings relatively short, and set "move the camera" with view settings dialogs (see Zoom tools settings dialog).

    With short focus distance you may move the camera behind the main object and be able to get to the object behind the main object.

    c) when you select the close object to you as first, make right click, then Mstn will try to select the object right behind it.

    Hope that helps.

    Personally, when modelling, I try to use 3D Connection mouse for navigation around the model, and for the selection: I use different views with combination of clip volume or Display set items.

    Nope it helps.

    Nikolay Vyglazov

  • Thanks for your reply, but my problem remains.

    CE's preference settings are different (offering fewer options), but I've set both to be "Never". Your suggestion that I "MUST be behind that surface" is incorrect because I'm able to snap to hidden vertices in v8i, and have always done so.

    Using Wireframe is not practical for complex models - I work in Illustration mostly. It worked perfectly in v8i - so I don't want to change my workflows. Constantly rotating my models to see geometry on the other side is not practical when I know a vertex is there and I want to snap to it.

    Focus distance and camera settings are not relevant to the problem - this applies to any type of view (close/ far/ wide angle/ isometric).

    My right-click is for datapoint reset - do you mean scrolling through tentative datapoints to find alternative geometry? I've set that to Alt>Data (never understood how anyone could the left/right chord as a tentative datapoint).

    I also use the 3D Connexion mouse, but mostly for setting up rendering views in Microstation, and always in LumenRT and Google Earth. View Rotate around a vertex is far more accurate and efficient for general 3D modeling.

    Here again is a summary of the issues - CE is not usable for me in these current circumstances. Again, hoping someone could help change that.


  • In CE I have set my "Locate Interiors" option to "Always" and it does find points hidden on the other side of shaded geometry, but you have to tentative several times to "drill" through the object. Something has has changed from v8i as it seem to order the "drilling" by "depth", and not "point closest too", the tentative point.

    However also look at UN-TICKING the:  AccuSnap settings box  > Elements > Find Elements By: > Interior of Filled Elements

  • Hi Max,

    in my opinion, what mentioned should solve the problem: In AccuSnap Settings dialog, to switch off Find Elements By: Interior of Filled Elements.

    With regards,