Multiframe version 21 new install - toolbars/ icons too small to see on laptop or monitor

Grateful if someone can help me. I've just purchased Multiframe version 21. I've tried it on 3 separate monitors and changed the Windows display settings but all that does is change the text font size, it doesn't increase the size of the toolbars/ icons. They are too small to see, so I can't choose the right icon, rendering the software unusable. Grateful for any advice. Thanks. 

Parents
  • I had this problem  too. There is a fix for this. This seems to be a DPI issue. Here is what you need to do. 

    1) Press Windows Logo key + R to open a Run. Type in regedit and press Enter.

    2) In the left pane of the Registry Editor, navigate to the following directory: 

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

    (This starts out as HKEY_LOCAL_MACHINE then click the little arrow to find SOFTWARE, then Microsoft, etc...)
    3) Click on SideBySide in the left pane to expand its contents in the right pane. Right-click on an empty space in the right pane, hover over New and click on DWORD (32-bit) value.

    4) Name the file PreferExternalManifest and press Enter. Right-click the new DWORD value and click on Modify. Type 1 into the Value Data. Change the value’s Base to Decimal.  Click on OK. Close the Registry Editor.

    5) Open NotePad and paste the following typical manifest:

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    
    <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
    
    <dependency>
      <dependentAssembly>
        <assemblyIdentity
          type="win32"
          name="Microsoft.Windows.Common-Controls"
          version="6.0.0.0" processorArchitecture="*"
          publicKeyToken="6595b64144ccf1df"
          language="*">
        </assemblyIdentity>
      </dependentAssembly>
    </dependency>
    
    <dependency>
      <dependentAssembly>
        <assemblyIdentity
          type="win32"
          name="Microsoft.VC90.CRT"
          version="9.0.21022.8"
          processorArchitecture="amd64"
          publicKeyToken="1fc8b3b9a1e18e3b">
        </assemblyIdentity>
      </dependentAssembly>
    </dependency>
    
    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
      <security>
        <requestedPrivileges>
          <requestedExecutionLevel
            level="asInvoker"
            uiAccess="false"/>
        </requestedPrivileges>
      </security>
    </trustInfo>
    
    <asmv3:application>
      <asmv3:windowsSettings xmlns="">schemas.microsoft.com/.../WindowsSettings">
        <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="">schemas.microsoft.com/.../ms_windowsSettings:dpiAware>
      </asmv3:windowsSettings>
    </asmv3:application>
    
    </assembly>
    6) Save the Notepad document as the full name of the executable file of the program you are trying to disable display scaling on high DPI devices for, followed by the .manifest extension. For example, the name of a manifest file for Multiframe would be Multiframe64.exe.manifest

    7)
    Move the manifest file to the root directory of the program you are trying to turn display scaling on high DPI devices off for – this is the directory where the program’s files, including its executable file (such as multiframe64.exe for Multiframe 64 bit) are located. An example of such a root directory is:

    C:\Program Files\Bentley/Offshore/Multiframe CONNECT Edition V22

    Done! This should be automatic. So just start up multiframe. If you have been messing with the scale of the app under properties and compatibility this may not work. To solve that problem just restore the property settings.

Reply
  • I had this problem  too. There is a fix for this. This seems to be a DPI issue. Here is what you need to do. 

    1) Press Windows Logo key + R to open a Run. Type in regedit and press Enter.

    2) In the left pane of the Registry Editor, navigate to the following directory: 

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

    (This starts out as HKEY_LOCAL_MACHINE then click the little arrow to find SOFTWARE, then Microsoft, etc...)
    3) Click on SideBySide in the left pane to expand its contents in the right pane. Right-click on an empty space in the right pane, hover over New and click on DWORD (32-bit) value.

    4) Name the file PreferExternalManifest and press Enter. Right-click the new DWORD value and click on Modify. Type 1 into the Value Data. Change the value’s Base to Decimal.  Click on OK. Close the Registry Editor.

    5) Open NotePad and paste the following typical manifest:

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    
    <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
    
    <dependency>
      <dependentAssembly>
        <assemblyIdentity
          type="win32"
          name="Microsoft.Windows.Common-Controls"
          version="6.0.0.0" processorArchitecture="*"
          publicKeyToken="6595b64144ccf1df"
          language="*">
        </assemblyIdentity>
      </dependentAssembly>
    </dependency>
    
    <dependency>
      <dependentAssembly>
        <assemblyIdentity
          type="win32"
          name="Microsoft.VC90.CRT"
          version="9.0.21022.8"
          processorArchitecture="amd64"
          publicKeyToken="1fc8b3b9a1e18e3b">
        </assemblyIdentity>
      </dependentAssembly>
    </dependency>
    
    <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
      <security>
        <requestedPrivileges>
          <requestedExecutionLevel
            level="asInvoker"
            uiAccess="false"/>
        </requestedPrivileges>
      </security>
    </trustInfo>
    
    <asmv3:application>
      <asmv3:windowsSettings xmlns="">schemas.microsoft.com/.../WindowsSettings">
        <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="">schemas.microsoft.com/.../ms_windowsSettings:dpiAware>
      </asmv3:windowsSettings>
    </asmv3:application>
    
    </assembly>
    6) Save the Notepad document as the full name of the executable file of the program you are trying to disable display scaling on high DPI devices for, followed by the .manifest extension. For example, the name of a manifest file for Multiframe would be Multiframe64.exe.manifest

    7)
    Move the manifest file to the root directory of the program you are trying to turn display scaling on high DPI devices off for – this is the directory where the program’s files, including its executable file (such as multiframe64.exe for Multiframe 64 bit) are located. An example of such a root directory is:

    C:\Program Files\Bentley/Offshore/Multiframe CONNECT Edition V22

    Done! This should be automatic. So just start up multiframe. If you have been messing with the scale of the app under properties and compatibility this may not work. To solve that problem just restore the property settings.

Children
No Data