AutoPlant piping data not saved to database

Project Database Error

"ATDB0619 : msvbvm60 is not properly registered. Components data will not commit to the database...."


This issue is related to Security Update for Microsoft Office 2010 (KB2589337) 64-Bit Edition.


There are two ways to restore AutoPlant functionality :

1.Register msvbvm60.dll in C:\Windows\SysWOW64
Open Run and type regsvr32  C:\Windows\SysWOW64\msvbvm60.dll

 2.Restore registry values for following keys. Change key value from 2.1 to 6.0
HKEY_CLASSES_ROOT\Interface\{A4C466B8-499F-101B-BB78-00AA00383CBB}\TypeLib
HKEY_CLASSES_ROOT\Interface\{A4C46780-499F-101B-BB78-00AA00383CBB}\TypeLib 

If this occurs in AutoPlant SS4 ATDB0619 error will be shown with information that will help to resolve this :

The consequence of this in AutoPlant SS3 :

In distributed project mode when a new drawing is created the database MDB file in not created.
While trying to save model changes following errors will be shown (ATDB0320 , ATDB0309 , ATDB0108) :

 

For existing document that has mdb database the data will be not saved to database, AutoCAD command line will not report that the piping data was added to the project (1 3D Piping Data Components added to the project.). Once this issue is noticed use (at_ProjectDB_repair) to recover 100% of data.

For Missing msvbvm60.dll file:

Sometimes while registering user might not find the file at defined folder location and prompt below message: 

The Module :C:\WINDOWS\SYSWOW64\msbvm60.dll" failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent.DLL files. The Specified module could not be found. 

      

Solution: 

User may download the msvbvm60.dll file for respective operating systems or may copy it from other existing machine. Please click here>>>msvbvm60.zipto download the one compatible for Win7. Rename it to .dll and paste it to folder location.

msvbvm60.dat_Rename to Dll
Anonymous
  • Dear Bentley Family,

    We are also getting error ATDB0619.

    With reference to link :

    communities.bentley.com/.../autoplant-piping-data-not-saved-to-database.aspx

    We already tried command “regsvr32  C:\Windows\SysWOW64\msvbvm60.dll” and it successfully registered also we crosscheck registry values from 2.1 to 6.0 and found 6.0correct, still we are getting this error while saving drawing.

    Please let me know the solution to fix this error.

    Waiting for your earliest reply.

    Note - We are using:

    Software :  Bentley Autoplant V8i - SS4 version : 8.11.9.140 , Autocad 2012-64Bit , Naviswork 2013 , MS-Office 2010 - 64 Bit.

    Hardware : Workstation Dell Precision T3600

    Thanks & Regards ,

    Swapnil M. Gholap

    Application Engineer