[ORD] VBA - SmartObjects Issues in ORD with Code that worked in Ss4

We have created a modified version of SmartObjects for our DOT Usage. We enhanced some of the command line arguments to accept Element Templates instead of level names or any other drawing parameters. One thing that was not 100% consistent was trying to set the elements created so the element templates are also assigned to the elements. Sometime the code worked and other times it did not.

But more glaring was our extension of the 3D pipes workflow concept. We decided to create extrusions of drainage structures to show where the underground vaults were. This had to be a "schematical" representation by taking the outline as shot, flattening it to its lowest point on the perimeter and then projecting it down to the lowest pipe invert found within its perimeter. In Ss4, it worked really well. Our Programmer, who does amazing work on conceptual ideas, even worked with our Manhole cell and made a 3D cylinder that determined is diameter using the largest size connecting pipe as its guide.

These worked great in Ss4, but in ORD CONNECT, the three D pipes work as designed, but the drainage structure extrusions were drawn using some unit conversion factor, so the were created way out in space, away from their "parent" survey figures. THis must be some error or revision in the VBA program code that is not explained or exposed in any documentation. I tried logging a TR, but without our full workspace and example file it went nowhere. The programmers don't seem to understand anything about how this code is accessed in ORD and why it is difficult to debug.

  

  • Chuck

    We have done much of what you have stated here as well (first paragraph). Using the command "Template Active" has worked 100% for us. So, a typical command line for placing text might be "TextEditor Place; Template Active Annotation\Sheets\Sheet Notes\Proposed\Alignments\Prop. Channel Txt; textstyle Active=0120_P-L120 LT". A typical command line for placing a linestring might be "Template Active Proposed\Linear\Roads Drives Ramps\Drives Ramps\P-Drive Com; place smartline". We have hundreds of these within a custom menu set represented through our GUI dgnlib. I wish I knew how to help you with your inconsistencies as it works so well for me. 

    Now, an issue we do have is that I desired a further extension of this notion by using such to not only define the element template, but to also set the active feature definition. That command is "Geometry setactive feature" which acts oddly from the command line. It will set the active feature (i.e. Geometry setactive feature (Feature definition location)) but the FD toolbar doesn't flip over to show it. Upon using the dropdown in that toolbar, it goes to that definition but such still requires the user to go to the FD toolbar which defeats the actual reasoning behind the GUI. So- for now- I am "somewhat" happy that the menus do set the element template, but am disappointed that I cannot take things further.

    On a somewhat related note, do you have any idea how to get the options within "Doccenter place label" can be changed via a command line string? the "placelabel" command gives us the options of, i.e. associationstate= on, off, etc. but "doccenter place label" presents no such options.

    So, yes, there would seem to be so many great options for us to use, but it is difficult to understand why things which used to work no longer do. As well, the documentation for so much of what we do is non-existent; just trial and error for most of my day.

    Regards,

    Mark

    Mark Anthony Plum
    Senior Designer, CADD Systems Development

    1601 N.W. Expressway, Suite 400
    Oklahoma City, OK  73118
  • Can we get it moved to there?


    Charles (Chuck) Rheault
    CADD Manager

    MDOT State Highway Administration

    • MicroStation user since IGDS, InRoads user since TDP.
    • AutoCAD, Land Desktop and Civil 3D, off and on since 1996