Which version of SDK and Visual Studio to use for OpenCities Map PowerView 10.6.0.5 (update 6)?

Hi All!

I would like to develop MDL C++ Add-In-s (using the MircrostationAPI) for the OpenCities Map PowerView (update_6) - version 10.6.0.5.

I've installed the application.

I've found the following SDK: OpenCities Map CONNECT Edition SDK x64 Update 6 (English)  --- https://softwaredownloads.bentley.com/en/ProductDetails/1941?buildid=20790

I tried to install but the installer fails with an error message. It says the OpenCities Map software is not installed. That's true. 

I've found an SDK for Microstation also: MicroStation CONNECT Edition SDK x64 (English) ---  https://softwaredownloads.bentley.com/en/ProductDetails/1000?buildid=18564

But I'm not sure if this is the right version to use?

I'm also not sure which Visual Studio version to use.

This site sasy I should use VS2015: http://www.la-solutions.co.uk/content/CONNECT/MicroStationAPI/VizStudio.htm

What do you think?

Thanks in advance.

Br

Miklos

Parents
  • Hi Miklos,

    because your question is about OpenCities Map, I recommend to move it to Geospatial Programming forum. As you can expect, MicroStation development specialist are not necessarily familiar with geospatial products. To move existing post, use More > Move tool under your original post.

    I would like to develop MDL C++ Add-In-s

    In my opinion you are mixing different terms, which leads to a confusing information:

    • MDL was a name of language + API + environment in its early days, but it has been used in many meanings. Today, MDL is in fact "any language and API, that can be used to develop MicroStation application".
    • C++ applications are usually referred as C++ or native ones.
    • add-ins are applications developed using managed (NET) API, because the application entry point is inherited from Addin class (which is different from native applications).
    I tried to install but the installer fails with an error message. It says the OpenCities Map software is not installed.
    But I'm not sure if this is the right version to use?

    It's explicitly written in SDK information:

    The SDK requires installation of OpenCities Map CONNECT Edition Update 6 and
    MicroStation CONNECT Edition Update 14 SDK. OpenCities Map is a Mapping
    software for editing, analysis, and management of 2D/3D geospatial
    information. Learn more about OpenCities Map versions here.

    I'm also not sure which Visual Studio version to use.

    The required Visual Studio version is always defined in PowerPlatform (MicroStation) SDK readme, on which a particular product (OpenCities Map) is based.

    Because OpenCities Map CE Update 6 is based on PowerPlatform CE Update 14, you can check MicroStation CE SDK readme that Visual Studio 2017 Professional is required to compile native code applications.

    This site sasy I should use VS2015

    It does not tell anything like this, because it does not focus on Bentley Map / OpenCities Map product line, but on MicroStation only.

    With regards,

      Jan

    Answer Verified By: Miklos Bodi 

Reply Children
No Data