[Explorer API] Export Revit File Issue

Hi Experts,

I'm trying to export Revit models from a folder in ProjectWise, I've tried to use these API functions:

aaApi_FetchDocumentFromServer

aaApi_CopyOutDocument

aaApi_ExportDocument

But they all failed, the return value is false, and only a 0k size file downloaded.

Please note I've used these APIs to export Microstaion Dgn files for many years, without any problem.

So what's the problem with Revit model exporting? Does anyone meet the same problem? Thanks a lot.

Parents
  • ,

    A little more detail would be helpful.  A code snippet would go a long way to providing some context, along with details such as which documents, their status, error messages (if any), as well as software versions, etc.

    I understand that you are a bit frustrated and want some help, but for some reason, it is common for folks to state a problem in a way that doesn't give a good starting point to troubleshoot any underlying problems.  It would be like stating a problem about your car not starting like this:  "My car won't start.  What's wrong with it?  It always started before."  You would give some context about the conditions along with what you have tried so far.

    And screenshots help a great deal. 

    Here's what I think I know so far:

    The return code indicates failure, so there would be an error code.  What are the errors?

    You say that "only a 0k size file is downloaded".  What do you mean by that?  If the functions fail, and a file is created, but is "empty", the file transfer must be starting, so I would start by checking things related to files, i.e. is there enough room on the device where the file is being created, time outs, security, networking, etc.  Also does this process work OK when using ProjectWise Explorer, or is it only failing in your code?

Reply
  • ,

    A little more detail would be helpful.  A code snippet would go a long way to providing some context, along with details such as which documents, their status, error messages (if any), as well as software versions, etc.

    I understand that you are a bit frustrated and want some help, but for some reason, it is common for folks to state a problem in a way that doesn't give a good starting point to troubleshoot any underlying problems.  It would be like stating a problem about your car not starting like this:  "My car won't start.  What's wrong with it?  It always started before."  You would give some context about the conditions along with what you have tried so far.

    And screenshots help a great deal. 

    Here's what I think I know so far:

    The return code indicates failure, so there would be an error code.  What are the errors?

    You say that "only a 0k size file is downloaded".  What do you mean by that?  If the functions fail, and a file is created, but is "empty", the file transfer must be starting, so I would start by checking things related to files, i.e. is there enough room on the device where the file is being created, time outs, security, networking, etc.  Also does this process work OK when using ProjectWise Explorer, or is it only failing in your code?

Children