Attention: PW Administrators -Expired Certificate Message

On May 1, 2015, users may see an expired certificate message in all versions of ProjectWise Explorer Client with ProjectWise integration Office 2010, 2013 and 365 modules when opening Microsoft Office files via ProjectWise.  This certificate was used for older 2003/2007 Office file formats.

 

It is possible to remove the files that are causing the error message to display.

  • Removing these files will eliminate expired certificate message for all Office files.

  • Attribute exchange will continue to work for MS Office 2007 and later.

 

Manually Fixing Post-2007 Microsoft Office Integration

 

X64 machines

 

  1. Go to C:\Program Files (x86)\Microsoft Office\OfficeXX*\STARTUP

  2. Delete idattr.dot

  3. Delete idAttributeExchange.dot

  4. Next go to C:\Program Files (x86)\Bentley\ProjectWise\bin\MSOffice\

  5. Delete idattr.xla

  6. Delete idAttributeExchange.xla

 

X86 machines

This applies to either x64 installation of MS Office and/or x86 MS Office installs on x86 machines.

 

  1. The files can be found in C:\Program Files\ Microsoft Office\OfficeXX*\STARTUP

  2. Follow steps 2 – 6 above.

 

*The file-path above will change depending upon the specific Office version installed. See the Examples below.

 

C:\Program Files (x86)\Microsoft Office\Office12\STARTUP for “MS Office 2007”

C:\Program Files (x86)\Microsoft Office\Office14\STARTUP for “MS Office 2010”

C:\Program Files (x86)\Microsoft Office\Office15\STARTUP for “MS Office 2013”

 

NOTE: These files may re-appear after a PW Integration repair/reinstall.

 

Manually Fixing Pre-2007 Microsoft Office Integration

 

Excel:

1. Get compiler error - press OK

2. Stop execution: Visual Basic for Applications menu: Run->Reset

3. Get back to Visual Basic for Applications, menu, Tools->References untick "MISSING: idattr.xla"

4. Rename older VBA macro functions: wpsWOdm_BuiltinProp and wpsWOdm_CustProp to GetDocumentProperty.

You can use find and replace all (Ctrl+H). Make sure scope is set to Workbook in Options

5. Save your workbook as Macro-Free workbook.

 

Word:

1. Get compiler error - press OK

2. Stop execution: Visual Basic for Applications menu: Run->Reset

3. Get back to Visual Basic for Applications, menu, Tools->References untick "MISSING: idattr.dot"

4. Save your document Macro-Free

Anonymous