Add-PWEnvironmentColumn

Anybody had issues or success with the 'Add-PWEnvironmentColumn' cmdlet?

I get SQL errors when it is run and it seems to be getting mixed up with the data types:-

e.g. PW 08.11.11.584: DB Oracle

Command1:
Add-PWEnvironmentColumn -EnvironmentName 'Default' -ColumnName 'MyNewTextAttribute' -ColumnType 'text' -ColumnWidth 100

Result1:
Error executing alter table ENV_Default add (MYNEWTEXTATTRIBUTE number(15))
Error executing SQL statement: 'alter table ENV_Default add (MYNEWTEXTATTRIBUTE number(15))'
Status: 32768.
Error: Error executing SQL select statement..


Command2:
Add-PWEnvironmentColumn -EnvironmentName 'Default' -ColumnName 'MyNewIntegerAttribute' -ColumnType 'integer'

Result2:
Error executing alter table ENV_Default add (MYNEWINTEGERATTRIBUTE varchar(0))
Error executing SQL statement: 'alter table ENV_Default add (MYNEWINTEGERATTRIBUTE varchar(0))'
Status: 32768.
Error: Error executing SQL select statement..


Command3:
Add-PWEnvironmentColumn -EnvironmentName 'Default' -ColumnName 'MyNewDecimalAttribute' -ColumnType 'decimal' -Columnwidth 10 -ColumnScale 2

Result3:
Error executing alter table ENV_Default add (MYNEWDECIMALATTRIBUTE varchar(10))
Error executing SQL statement: 'alter table ENV_Default add (MYNEWDECIMALATTRIBUTE varchar(10))'
Status: 32768.
Error: Error executing SQL select statement..


Command4:
Add-PWEnvironmentColumn -EnvironmentName 'Default' -ColumnName 'MyNewDateAttribute' -ColumnType 'date'

Result4:
Error executing alter table ENV_Default add (MYNEWDATEATTRIBUTE varchar(0))
Error executing SQL statement: 'alter table ENV_Default add (MYNEWDATEATTRIBUTE varchar(0))'
Status: 32768.
Error: Error executing SQL select statement..