Missing something easy in getting PowerShell for PW going...

Ok, this is a going to be an easy for someone to answer...

I am new to the PowerShell ProjectWise concept and trying hard to learn to get needed functionality.

But I cannot get Powershell to recognize that the Modules are installed and the functions exposed...

Supposedly I have the PWPS_DAB Module installed.

Tried the standard "Windows PowerShell ISE" and got the message that the architecture was wrong...

Import-Module -Name PWPS

Import-Module -Name PWPS_DAB -DisableNameChecking

Import-Module : The specified module 'PWPS' was not loaded because no valid module file was found in any module directory.

At line:1 char:1

+ Import-Module -Name PWPS

+ ~~~~~~~~~~~~~~~~~~~~~~~~

+ CategoryInfo : ResourceUnavailable: (PWPS:String) [Import-Module], FileNotFoundException

+ FullyQualifiedErrorId : Modules_ModuleNotFound,Microsoft.PowerShell.Commands.ImportModuleCommand

Import-Module : The current processor architecture is: Amd64. The module 'C:\Program

Files\WindowsPowerShell\Modules\PWPS_DAB\\PWPS_DAB.psd1' requires the following architecture: X86.

At line:3 char:1

+ Import-Module -Name PWPS_DAB -DisableNameChecking

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

+ CategoryInfo : ResourceUnavailable: (C:\Program File...0\PWPS_DAB.psd1:String) [Import-Module], InvalidOperationExce


+ FullyQualifiedErrorId : Modules_InvalidProcessorArchitecture,Microsoft.PowerShell.Commands.ImportModuleCommand

So then I tried the "Windows PowerShell ISE (x86)" and got the message that "open-pwconnection" is not recognized...

$result = open-pwconnection "any"

The term 'open-pwconnection' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was

included, verify that the path is correct and try again.At line:1 char:11

+ $result = open-pwconnection "PW Dev"

+ ~~~~~~~~~~~~~~~~~

+ CategoryInfo : ObjectNotFound: (open-pwconnection:String) [], CommandNotFoundException

+ FullyQualifiedErrorId : CommandNotFoundException

Neither ISE session will show the PW Module Commands in the "Command" Add-on.

What is the obvious thing that I am missing?

Parents Reply Children
No Data