1.21.0.0 Install Issue

I am getting notified on PWPS_DAB start up that a new version exists (1.21.0.0) but when I try to install it fails and I have to revert back manually to 1.20.6.0.  Is anyone else having an issue with 1.21.0.0?