GeoPak install with Windows 7 - GEOPAK | InRoads | MX | OpenRoads Forum - GEOPAK | InRoads | MX | OpenRoads - Bentley Communities

GeoPak install with Windows 7

I need some help!  I have a new computer with the following setup:

Windows 7 Pro SP1

3.2 Ghz AMD Phenom II processor

8 GB ram

64 bit os

At my office we have Microstation V8 ( and GeoPak (  I have installed both programs in the (x86) directories and Microstation works just fine.  However, the "applications" menu pulldown for GeoPak does not show up when I start Microstation.  I'm assuming it has something to do with the 64bit OS and the older software, but can't seem to figure out the secret.  Does anyone know why GeoPak won't startup with Microstation?  Is there something that I needed to do during install that I skipped? or is there some configuration variables that need to be changed?  Any help would be greatly appreciated!



7 Replies (Most Recent Reply)

  • Steve,

    A debug report would help determine if there are problems with the configuration variables.  Could you create one and attach it to your post?

    - Adam 

    (edit: had the wrong link at first)

    MicroStation & GEOPAK

  • In reply to Adam Wuellner:

    Here is the debug report, hopefully it will help.

  • Hi Steve,

    have you checked the GEOPAK readme to ensure that version is certified on Win 7?

    If it isn't, you may be wasting your time trying to get it operational.


  • In reply to MichaelGilham:

    I finally got on with tech support at Bentley and found out some things.  It turns out that v8 and v8i are both compatible with Windows 7, so that clears up that question for anyone else wondering.

    The geopak not loading correctly was either my fault during the install or the installer itself, (it's hard to tell at this point)  It turns out that the geopak.cfg file was installed or saved in the incorrect location and the v8i version was trying to access the v8 configuration, while the v8 configuration was not even in the correct place, so consequently it wouldn't load at all.  The tech support guy copied the respective geopak.cfg files to the correct folders and voila!  everything worked.  It all comes down to having the .cfg file in the correct location so that Microstation knows where to find it. 

    For reference here are the file paths that they were saved to:

    for the V8 2004 edition

    C:\Program Files (x86)\Bentley\GEOPAK

    C:\Program Files (x86)\Bentley\Program\MicroStation\config\appl

    for the V8i installation

    C:\Program Files (x86)\Bentley\GEOPAK\V8.11

    C:\Program Files (x86)\Bentley\MicroStation V8i (SELECTseries)\MicroStation\config\appl

    To tell the difference between the two cfg files look for the following lines near the top of the file using Notepad to edit:

    for V8i - % if defined (Load_GeoPak_SS2)

    for V8 - % if !defined (GPK_Start)

     Hope that helps someone else down the road that runs into a similar issue.  Thanks again for the input and help!



  • In reply to stvwebphoto:

    "It turns out that v8 and v8i are both compatible with Windows 7, so that clears up that question for anyone else wondering"


    Compatible and Supported are two different things. We recently had to go to w7 and had issues with v8 the first day. The response from bentley was load v8i. No effort would be expended on thier part to help resolve ANY issues with v8 running on the w7 platform.

  • In reply to GregGr:

    V8 does run on Windows 7, that's all I was saying in case someone else wasn't sure if it would or not. Ok so it's not supported any longer, that's the price you pay for not moving up to the newer versions.  Having to troubleshoot issues is part of the job in my opinion.  You cannot expect Bentley to support older versions of software indefinitely.  Whenever you install a program on a new operating system, there will be issues that's just the nature of the beast.

  • We have the same problem but I already fixed it but inside the application using APPLICATION\ GEOPAK\ SITE PLANS PREPARATION\ DRAW PROFILE TABULAR DATA ... the elevations of the existing and proposed profiles doesn't show up! Can you help me to solve this issue!

    I'm using WINDOWS 7 - Microstaion V8 GEOPAK (

^ Go to first post