Error - 'Microsoft.ACE.OLEDB.12.0' provider not registered - SOLVED

Bentley's supposed answer here is completely useless.

I figured someone ought to post something that actually gets OLEDB working.

I was attempting to read an .xlsx file into the SUDA Model Builder but kept getting the error that the OLEDB wasn't registered.  Below is my solution.

Enable OLEDB

This is an antiquated method that some programs still use to read MS Office documents.  Naturally, that means it’s required to run the USTN SUDA Model Builder as shown below.


1. Download the 32 bit 2010 version here. (

a. Attempting to install the package will give an error saying that all MS Office applications must first be uninstalled. Like we’re really going to do that… smh

2. Save the .exe directly to your C:/ drive to make it easier to find later

3. Run command prompt as an administrator

4. Type “cd/” and press ENTER

a. Takes you to C:/ directory

b. Type “AccessDatabaseEngine.exe /quiet” and press ENTER

1. The name of your exe may vary

5. Check the Add or Remove Programs part of Windows Settings to verify that the database engine was installed

6. The Model Builder will now work properly.

a. If it doesn't, uninstall and try the other install packages offered by Microsoft for 32 and 64 bit for 2010 and 2016 until you find the one that works for you.

Parents Reply Children
No Data