Openroads files crash upon clicking "update from library"

Hello everyone,

I have a file I've worked on for a few months now and just recently I've encountered a problem (probably with dgnlibs): when I open the file and click update from standards in the standards category, the file crashes. I tried many solutions from the forum, I tried to find some workarounds or clear the file but nothing works.

  1. Cleared user preferences - didn't work at all
  2. Compressing the file doesn't work
  3. Cleared dgnlibs (text favs, levels, annotations dgnlib) - didn't work
  4. I tried to delete some elements in the files - ORD keeps crashing every time I touch alignments

For the record, I had this issue some 3-4 months ago and I "resolved" it by removing feature definitions, symbologies, and all the other categories 1 by 1 in the model file. Only after deleting some of them could I finally update the standards and work as before.

There is 1 more thing worth mentioning - I encountered this issue simultaneously with another problem shown below (alignments lost their properties and the wheel next to complex element keeps spinning).


If anyone has any idea how to resolve these issues then please let me know. I couldn't find any similar problems on the forum. Thanks in advance for any response.