ORD 2020 R3 Update 9 - Annotate XS Template Points


I have recently come across an issue with XS annotation group that was copied from the delivered workspace.  The specific group is the XS Grid w/Annotation and the Annotation Definition XS Point Annotation.  As a double check, I opened ORD using the delivered configuration Training-Imperial and received the same error.

The error is an unhandled exception error and I receive it anytime I try and select a template that does not contain a point with a feature name override that contains the word "construction".  For example:

I have the delivered template library loaded:

I then manage the annotation group and then load a template from the template library:

I then edit the XS Point Annotation to select a point from the template I just loaded and it works because it contains a point with a feature name override:the name "construction" in it"

But if I change the template that does not contain a point with a feature name override the word "construction" in it I get an error message:

I thought maybe if I removed the list of points that are already loaded with the annotation definition that would help but nope:

The reason I am posting this is I have a project template library that does not contain points with the word "construction" in them either normal or feature name overrides.  I have also tried to create a new annotation group and annotation definition.  Has anyone else run into this?



********** EDIT *********

During my first set of tests I thought the issue had to due with a point containing the word "construction" but after further tests, it seems that at least one point in a template has to have a feature name override set or the error persists.  I have since edit my template library so that each template contains at least one point that has a feature name override.  I have edited the post to reflect that.

  • Yes I have experienced this as well and also thought it required a specific override name, but any one override will work.
    I have been overriding the last point of an end condition.

    We work in ProjectWise and I have not been able to rule out side effects from it.
    Sometimes when Selecting/Creating a template file *.itl  I get this ORD error

    I have not been able to confirm if this has anything to do with the annotation issue though...