Windows 11 and SELECTseries 10 Products

Are there any know issues with the SELECTseries 10 products after upgrading to Windows 11?

I use Power InRoads and it seems to be far less stable since the upgrade. 

For example, after running a few commands, I tried to key-in a command and in the middle of my typing, the [product name] Has Stopped Working dialog box opened and after sending the email, the session abruptly closes. Similar occurrences have happened many times with generally innocuous workflows.

I remoted into my office computer and there, on Windows 10, these same workflows operate as usual. I even tried setting the compatibility mode to Windows 8 as 10 was not an option but the problems persist..

  • Hi caddcop,

    I am not aware of a single page that documents Windows 11 support for all Bentley products. Each product/brand may keep track of this separately. For example this article for the OpenFlows products. Since you asked specifically about Power Inroads, I have moved your post to the Civil Forum where a specialist should be able to assist for that product.


    Regards,

    Jesse Dringoli
    Technical Support Manager, OpenFlows
    Bentley Communities Site Administrator
    Bentley Systems, Inc.

  • MicroStation and MicroStation based vertical products have not been certified for the Windows 11 envirionment. While there are plans to support Windows 11 in future updates of CONNECT versions this does not extend to V8i based versions as support for the platforms is expiring, see:

    https://communities.bentley.com/products/w/products__wiki/5205/bentley-product-support

    Answer Verified By: caddcop 

  • Here is the Event Log Details when it crashes. This is a Direct 3D issue of some sorts.

    Log Name: Application
    Source: Application Error
    Date: 3/8/2022 4:08:35 PM
    Event ID: 1000
    Task Category: (100)
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: CADDCOP-ROG
    Description:
    Faulting application name: PowerInRoads.exe, version: 8.11.9.918, time stamp: 0x5d00a746
    Faulting module name: d3d11.dll, version: 10.0.22000.120, time stamp: 0xbdc96957
    Exception code: 0xc0000005
    Fault offset: 0x00149d3f
    Faulting process id: 0x2944
    Faulting application start time: 0x01d833305945e166
    Faulting application path: C:\Program Files (x86)\Bentley\PowerInRoads V8i (SELECTSeries)\PowerInRoads\PowerInRoads.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\d3d11.dll
    Report Id: a5c2f9da-052e-40db-ba45-53b30469963a
    Faulting package full name:
    Faulting package-relative application ID:
    Event Xml:
    <Event xmlns="">schemas.microsoft.com/.../event">
    <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>100</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2022-03-08T21:08:35.3990432Z" />
    <EventRecordID>12013</EventRecordID>
    <Correlation />
    <Execution ProcessID="27972" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>CADDCOP-ROG</Computer>
    <Security />
    </System>
    <EventData>
    <Data>PowerInRoads.exe</Data>
    <Data>8.11.9.918</Data>
    <Data>5d00a746</Data>
    <Data>d3d11.dll</Data>
    <Data>10.0.22000.120</Data>
    <Data>bdc96957</Data>
    <Data>c0000005</Data>
    <Data>00149d3f</Data>
    <Data>2944</Data>
    <Data>01d833305945e166</Data>
    <Data>C:\Program Files (x86)\Bentley\PowerInRoads V8i (SELECTSeries)\PowerInRoads\PowerInRoads.exe</Data>
    <Data>C:\WINDOWS\SYSTEM32\d3d11.dll</Data>
    <Data>a5c2f9da-052e-40db-ba45-53b30469963a</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    </EventData>
    </Event>

    Maybe someone can use this information.


    Charles (Chuck) Rheault
    CADD Manager

    MDOT State Highway Administration

    • MicroStation user since IGDS, InRoads user since TDP.
    • AutoCAD, Land Desktop and Civil 3D, off and on since 1996
  • Using this information, I went into my laptop Display settings and loaded the NVidia control Panel. In it I configured it to use the NVidia when running Power InRoads Ss10. Since then, no problems. 


    Charles (Chuck) Rheault
    CADD Manager

    MDOT State Highway Administration

    • MicroStation user since IGDS, InRoads user since TDP.
    • AutoCAD, Land Desktop and Civil 3D, off and on since 1996