MDL Loader trying to load a folder as an application?

Hello All,

We are running into some issues with ORD 2021R2. For some reason, after opening a file, a command prompt window opens with some MDL loader errors. The error appears for all users. Our workspaces and workset configurations are stored on a network drive. I've included a few of these error messages below, plus a link to a screenshot.

MDL Loader: Could not load application C:\Program Files\Bentley\OpenRoads Designer CE 10.10\OpenRoadsDesigner\mdlsys\

MDL Loader: Could not load application C:\Program Files\Bentley\OpenRoads Designer CE 10.10\OpenRoadsDesigner\Cifs\

MDL Loader: Could not load application C:\Program Files\Bentley\OpenRoads Designer CE 10.10\OpenRoadsDesigner\mdlsys\**all subfolders**

/resized-image/__size/1212x496/__key/communityserver-discussions-components-files/5922/6470.MDL-Errors.png

I went ahead and uninstalled/reinstalled ORD and am getting the same error.

I also checked the forums but was only able to find information on fixing MDL errors that are pointed to specific .ma or .dll files, never for folder paths.

Does anyone have experience with this issue? I wondered if maybe it was a Microsoft issue affecting the DLLs?

Thank you!

Parents
  • Hello Baylor,

    It might be due to the error during the installing or workspace has changed.

    Did you get the same mdl load error when you opening a file locally ?

    Did you cleanup the registry when you uninstalled and reinstalled the application ?

    I would suggest you to please uninstall complete OpenRoads Designer and do registry cleanup.

    Please use the link below for uninstallation.

    Uninstall Process for OpenRoads Designer - OpenRoads | OpenSite Wiki - OpenRoads | OpenSite - Bentley Communities

    Please get full access from admin person of your system after that proceed for reinstallation of OpenRoads Designer.

    Regards,

    Purva Lakde

  • Hi Purva,

    Thank you for your suggestions! I completed the uninstall/reinstall process per the link provided, but I'm still receiving the same error messages when opening our project files using our standards.

    One update: I tested opening a file locally (using the example workspace/workset provided with the fresh ORD install) and did not receive the error messages! So, I guess that means it's something wrong with our civil/workspace/workset standards configuration.

    Our standards are enabled by deleting everything in the C:\ProgramData\Bentley\OpenRoads Designer CE 10.10\Configuration\ folder and replacing the ConfigurationSetup.cfg with a custom one that points to our network drive containing our DOT and internal standards. It's just strange that the majority of the MDL Loader errors refer to the C: drive MDLs (although it looks like some of our internal ones being caught as well)..

    Best,

    Baylor


    ORD 2021 R2  | MS CONNECT 17| PowerGEOPAK SS10


    Baylor Wagehoft, PE | Engineer IV - PMIT | bmwagehoft@mstutz.com

    Maurer-Stutz, Inc.

    We are hiring!

  • Hi Maryb,

    I agree, normally we would prefer not to delete any files that Bentley natively installs. However, this is the procedure outlined by our firm's base standards provider (Illinois DOT). I tried an install again and this time kept the installed files, modified the ConfigurationSetup.cfg to point to our standards on the network drive, and opened up a file to see if that fixed anything. No luck. The only thing it does differently is add the default example workspaces to the workspace drop-down list (in addition to our internal workspaces).

    We have been using this configuration scheme for over two years now with no error messages. It's hard to tell what update/configuration change may have caused it (feels like we are constantly tweaking things), but it has only happened since our somewhat recent update to ORD 2021R2. 

    So far, we haven't seen any decrease in functionality of ORD. Getting tempted to just tell our users to "deal with it", but wow is that frustrating when it was working without error before...

    Best,

    Baylor


    ORD 2021 R2  | MS CONNECT 17| PowerGEOPAK SS10


    Baylor Wagehoft, PE | Engineer IV - PMIT | bmwagehoft@mstutz.com

    Maurer-Stutz, Inc.

    We are hiring!

  • Hi Baylor,

    We are using the IDOT configuration as well and do not delete anything in the C:\ProgramData\Bentley\OpenRoads Designer CE 10.10\Configuration\ folder.  Instead, we modify the ConfigurationSetup.cfg to point to our network configuration using the _USTN_CUSTOM_CONFIGURATION variable.  We do not receive error messages.

    Sean

  • Hi Sean,

    I actually went ahead and did this after posting my response to MaryB. I agree, it's unnecessary to delete the Bentley example configuration. Moving forward we will not be deleting those files and just modifying the _USTN_CUSTOM_CONFIGURATION variable in the installed ConfigurationSetup.cfg. However, this was not fix for my issue.

    I was able to track it down though....much to my embarrassment. Looks like I was incorrectly assigning the MS_DGNAPPS variable in our internal org-civil standards (which we use to supplement IDOT's org-civil base standards). Lesson learned.

    Thanks everyone for the motivation to keep troubleshooting! Hopefully my mistake helps someone in the future!

    Baylor


    ORD 2021 R2  | MS CONNECT 17| PowerGEOPAK SS10


    Baylor Wagehoft, PE | Engineer IV - PMIT | bmwagehoft@mstutz.com

    Maurer-Stutz, Inc.

    We are hiring!

    Answer Verified By: Baylor Wagehoft 

  • I'm glad you were able to solve it!

    MaryB

    Power GeoPak 08.11.09.918
    Power InRoads 08.11.09.918
    OpenRoads Designer 2021 R2

        

  • Baylor:

    It is always good when it is something as simply as scanning a *.cfg. I make many changes to ours as well, but have made a habit of documenting such changes within the file; i.e. # ------The following modification was made for XXXX, MAP, 2022.09.30------ It appears like you are doing the same!

    Mark

    Mark Anthony Plum
    Senior Designer, CADD Systems Development

    1601 N.W. Expressway, Suite 400
    Oklahoma City, OK  73118
Reply Children
No Data