SDK Out-of-Process example application using the SCadSDK.3.0.DLL

[PowerGEOPAK SS2 SS3 - C#.NET, VB.NET]

[InRoads SS2 SS3 - C#.NET, VB.NET]

[Visual Studio 2012, .NET 3, 4]

[Windows 8.1]

I'm working on accessing SS2 ALG file to modify names of key data, for which you provided the InRoads SDK.

 

I received the SDK and installed. After several programming tries with PowerGEOPAK Selectseries 2 (8.11.07.56), I also installed PowerGEOPAK SELECTseries 3 (08.11.09.644) that includes the InRoads SDK (recently added). Finally, I installed InRoads SELECTseries 3 (08.11.09.493).

 

I have a pretty good idea about how things should work. I have developed in-process, out-of-process, mdl, mcsl and mvba, applications for MicroStation/PowerGEOPAK and similar applications for AutoCAD/Civil 3D... but at present...

 

I'm trying to run the SDK Out-of-Process example application using the SCadSDK.3.0.DLL found in the following locations,

 

·         C:\Program Files (x86)\Bentley\PowerGEOPAK V8i (SELECTseries 3)\PowerGEOPAK\RoadWayDesign\bin

·         C:\Program Files (x86)\Bentley\PowerInRoads V8i (SELECTseries 3)\PowerInRoads\RoadWayDesign\bin

 

With the Bentley Provided SDK, PowerGEOPAK SS2, and finally with InRoads SS3 SDK...

 

·         C:\Program Files (x86)\Bentley\PowerInRoads V8i (SELECTseries 3)\PowerInRoads\InRoadsGroup\sdk

 

The help refers to the SCadSDKxx.DLL so referred to this Unmanaged DLL with DLLImport or (Declare) in .NET (and every other way I could think of).

 

I can't seem to get things going.  It just won't load (Unable to load DLL 'SCadSDK.3.0.DLL': The specified module could not be found. (Exception from HRESULT: 0x8007007E). I checked the DOS Environment variable Path, and included the DOS formatted path, I'm compiling 32 bit, tried .NET 2 and .NET 3.5; I am running Visual Studio 2012 on a Windows 8.1 workstation.

 

What ".net", Windows version, and Visual Studio version should work?  I need some help getting this started.

 

I am trying the example out-of-process .net application and I can't get past the Initialization call (I'm fully licensed, but it never gets that far).  I've tried numerous times with the same or similar results.  I know it finds the SCadSDKxx.DLL, but I keep getting the error mentioned above and can't determine which (if any) dependencies are missing.  Dependency Walker shows lots of Red, but it shows the same for DLLs I know work.